Dupli_City

Dupli_City

Should you trust those who’ve betrayed you?

Dupli_City is a cyberpunk narrative game about the value of trust in a world full of betrayal. Set in Grid City decades in the future, a band of outcasts seeks to stop a megacorp A.I. hellbent on population cleansing.

You play as Claire, a young woman gifted with psychic powers. Use your powers to help the party in their mission to destroy the corrupt A.I. Assist the party in choosing co-conspirators across the city, selecting who to send on missions, and leveling up skills to take on harder missions as you get closer to the final showdown. But don’t neglect the relationships between your party members. You need to earn their trust by helping them make good relationship decisions and life choices. Learn who they truly are or all will be lost.

In the face of overwhelming odds, the party’s only hope of succeeding is learning to trust each other. Can you hold them together and help them save Grid City or will the megacorp destroy all of you?

Features

  • Earn the trust of 6 characters in your party: the subject, the android, the terrorist, the renowned musician, and the vampires
  • Traverse 4 unique sectors in the city and convince a co-conspirator to join forces with you in each sector
  • Allocate party members to tasks each day including missions to please your co-conspirator, lessons to level up skills, and strikes to weaken the megacorp
  • Make choices that have downstream impacts on relationships and the final outcome of your efforts
  • Gather rare intel to uncover the dark secrets of party members’ past betrayals
  • Engage in a final showdown with a corrupt A.I. where the balance of everything hangs on your choices and knowledge
  • Original score styling eleven tracks laden with betrayal, tension, and occasional existential dread
  • Robot cat
  • Cool. Ice cream truck

 

PC requirements:
Minimum:
  • OS: Windows XP SP2+
  • Processor: SSE2 instruction set support
  • Graphics: DX9 (shader model 3.0) or DX11 with feature level 9.3 capabilities

MAC requirements:
Minimum:
  • OS: Mac OS X 10.9+
  • Processor: SSE2 instruction set support
  • Graphics: DX9 (shader model 3.0) or DX11 with feature level 9.3 capabilities

Leave a Reply

Your email address will not be published. Required fields are marked *

You may be also interested in these game's requirements: